Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Projetos de ESP32
Marcelo Sorge
Membro
Mensagens: 1
Registrado em: 04/Out/2018, 03:01

Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por Marcelo Sorge » 04/Out/2018, 18:52

Olá a todos do fórum, sou iniciante com microcontroladores e C++ e estou encontrando dificuldades básicas em fazer o meu ESP32 se comunicar com sketchs extremamente simples, me desculpem pela minha ignorância, mas quero muito aprender a programar o ESP32.

O que ocorre é o seguinte, eu estou tentando fazer coisas simples como piscar led e imprimir o hello wolrd, mas parece que esta dando erro de porta serial e biblioteca, eu fiz exatamente como o Fernando ensinou na vídeo dele sobre a instalação do ESP na IDE do Arduíno, e não funcionou, achando que poderia ser alguma coisa com o IDE eu desinstalei e instalei de novo e continuou com o mesmo erro, será que alguém poderia me dar uma dica o que eu posso estar fazendo de errado? Será que eu queimei a plaquinha :o :oops:

O Erro que aparece na IDE é esse:

O sketch usa 196288 bytes (14%) de espaço de armazenamento para programas. O máximo são 1310720 bytes.
Variáveis globais usam 14120 bytes (4%) de memória dinâmica, deixando 313560 bytes para variáveis locais. O máximo são 327680 bytes.
esptool.py v2.5.0
Serial port COM8
Connecting........_____....._____....._____....._____....._____....._____.....____Ocorreu um erro enquanto o sketch era carregado
_

A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header
Biblioteca inválida encontrada em C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\AzureIoT: no headers files (.h) found in C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\AzureIoT
Biblioteca inválida encontrada em C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\BLE: no headers files (.h) found in C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\BLE
Biblioteca inválida encontrada em C:\Users\Marcelo Sorge\Documents\Arduino\libraries\esp32-rgb-homebridge-master: no headers files (.h) found in C:\Users\Marcelo Sorge\Documents\Arduino\libraries\esp32-rgb-homebridge-master
Biblioteca inválida encontrada em C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\AzureIoT: no headers files (.h) found in C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\AzureIoT
Biblioteca inválida encontrada em C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\BLE: no headers files (.h) found in C:\Users\Marcelo Sorge\Documents\Arduino\hardware\espressif\esp32\libraries\BLE
Biblioteca inválida encontrada em C:\Users\Marcelo Sorge\Documents\Arduino\libraries\esp32-rgb-homebridge-master: no headers files (.h) found in C:\Users\Marcelo Sorge\Documents\Arduino\libraries\esp32-rgb-homebridge-master

Este relatório teria mais informações com
"Mostrar a saida detalhada durante a compilação"
opção pode ser ativada em "Arquivo -> Preferências"


Obrigado a todos que puder me ajudar.
M

ricardo.mueller
Membro
Mensagens: 1
Registrado em: 05/Out/2018, 15:27

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por ricardo.mueller » 05/Out/2018, 15:47

Também estou tendo este mesmo problema. Até pensei que pudesse ser um problema na própria plaquinha do ESP32. Mas o estranho é que no Windows, aparece o dispositivo no gerenciador de dispositivos e que foi atribuído a COM4 para a comunicação com o PC.

GabrielMajaron
Membro
Mensagens: 27
Registrado em: 05/Jun/2018, 15:52

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por GabrielMajaron » 09/Out/2018, 11:27

Olá Marcelo!
Qual ESP32 está usando?
Se existir, tente pressionar o botão IO0 do ESP enquanto aparecer a mensagem "Connecting" durante a gravação do sketch, tente com outros botões também (EN, Boot...).

Espero que isso resolva :mrgreen:

GabrielMajaron
Membro
Mensagens: 27
Registrado em: 05/Jun/2018, 15:52

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por GabrielMajaron » 09/Out/2018, 11:31

Tente mudar as configurações da IDE.
Em Ferramentas -> Flash Frequency, mude para 40MHz
Em Ferramentas -> Upload Speed, mude para 115200

Amoraes
Membro
Mensagens: 4
Registrado em: 07/Nov/2018, 01:30

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por Amoraes » 07/Nov/2018, 01:37

Também estou tendo este problema.

Instalei em 2 PCs diferentes, um com Windows 10 e outro com Windows 7, testei com 2 placas similares compradas de fornecedores diferentes, dois cabos diferentes e mais de uma porta em cada PC (um é note).

Um amigo que instalou da forma antiga (em outro estado) não teve problemas.
Estou propenso a instalar o IDE do zero e fazer tudo pela forma antiga (nunca fiz).

Se alguém tiver achado a solução, poste aqui por favor!

Amoraes
Membro
Mensagens: 4
Registrado em: 07/Nov/2018, 01:30

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por Amoraes » 07/Nov/2018, 01:38

GabrielMajaron escreveu:
09/Out/2018, 11:31
Tente mudar as configurações da IDE.
Em Ferramentas -> Flash Frequency, mude para 40MHz
Em Ferramentas -> Upload Speed, mude para 115200
Testei varias velocidades e varias alterações na configuração. Nao resolveu.

GabrielMajaron
Membro
Mensagens: 27
Registrado em: 05/Jun/2018, 15:52

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por GabrielMajaron » 07/Nov/2018, 20:19

GabrielMajaron escreveu:
09/Out/2018, 11:27
Olá Marcelo!
Qual ESP32 está usando?
Se existir, tente pressionar o botão IO0 do ESP enquanto aparecer a mensagem "Connecting" durante a gravação do sketch, tente com outros botões também (EN, Boot...).

Espero que isso resolva :mrgreen:
Tentou isto?

Amoraes
Membro
Mensagens: 4
Registrado em: 07/Nov/2018, 01:30

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por Amoraes » 08/Nov/2018, 17:50

GabrielMajaron escreveu:
07/Nov/2018, 20:19
GabrielMajaron escreveu:
09/Out/2018, 11:27
Olá Marcelo!
Qual ESP32 está usando?
Se existir, tente pressionar o botão IO0 do ESP enquanto aparecer a mensagem "Connecting" durante a gravação do sketch, tente com outros botões também (EN, Boot...).

Espero que isso resolva :mrgreen:
Tentou isto?
Putz!

Era isso, so apertar o reset na hora de carregar. Desculpe-me! Nao sabia disso.

Marinheiro de primeira viagem com ESP

Obrigado mesmo, Gabriel !!!

GabrielMajaron
Membro
Mensagens: 27
Registrado em: 05/Jun/2018, 15:52

Re: Duvidas sobre como instalar as bibliotecas para ESP32 e Bugs na IDE do Arduino

Mensagem por GabrielMajaron » 08/Nov/2018, 20:09

Por nada!

Não esqueça de marcar como resolvido o tópico

:mrgreen:

Responder